Jetpack 9.0 即将推出:更新了短代码嵌入模块以处理 Facebook 和 Instagram oEmbeds

Facebook 和 Instagram 将于 10 月 24 日放弃未经身份验证的 oEmbed 支持.WordPress 将在即将发布的版本中删除 Facebook 和 Instagram 作为 oEmbed 提供商.在评估第三方解决方案后,WordPress VIP 建议其合作伙伴启用 Jetpack 的短代码嵌入模块.Jetpack 将在其 9.0 版本中发布更新,预计将在 10 月 24 日截止日期之前登陆.

该模块正在更新,以便为可能受到 Facebook 即将到来的 API 更改负面影响的用户提供无缝过渡.WordPress 贡献者已经运行了一些模拟,但还不确定以前嵌入的内容的显示会发生什么.

“他们可能会更改 JS 文件的内容以操作缓存的嵌入,也许是为了显示警告,表明该站点正在使用旧方法嵌入内容或请求未正确验证,” Jonathan Desrosiers 评论了删除 oEmbed 提供程序的 trac 票证.

WordPress.com VIP 粗略地概述了如果用户不启用开始对 oEmbeds 进行身份验证的解决方案,他们可以期待什么:

默认情况下,WordPress 在帖子元数据中缓存 oEmbed 内容.这些嵌入将继续显示在以前发布的内容中.如果您在块编辑器中编辑较旧的帖子,无论您是否通过保存更改来更新帖子,帖子中的嵌入都将不再被缓存并停止显示. 如果您使用经典编辑器查看这些较旧的帖子,只要帖子未重新保存,嵌入内容将继续正常运行和显示.如果您更新帖子内容,除非您安装了缓解措施,否则嵌入将停止运行.

尽管 WordPress VIP 建议使用 Jetpack 模块作为最佳解决方案,但自托管 WordPress 用户如果尚未使用 Jetpack,则可能希望研究其他选项.oEmbed Plus 是一个免费插件,专门用于解决 WordPress 将 Facebook 和 Instagram 作为 oEmbed 提供商删除的问题,但设置和配置需要做更多工作.它要求用户注册为 Facebook 开发者并创建应用以获取 API 凭据.

VPS1352主机测评网(www.vps1352.com)
本文链接:https://www.vps1352.com/7424.html

2
订阅评论
提醒
0 评论
内联反馈
查看所有评论