Drupal系统要求

Drupal是建立网站的开源内容管理系统。本指南打算在安装和运行Drupal之前通知Hostwinds客户对Drupal系统要求感兴趣的。这是许多客户在主机Winds入门时选择许多客户选择的更常见的应用程序之一。本指南也与主机云,VPS和专用服务器客户相关联,这些客户端正在寻求配置其Web托管服务以支持特定版本的Drupal。

Drupal 7要求

磁盘空间

最低安装需要15兆字节。 具有许多贡献模块和主题的网站需要60 MB。 请记住,您需要更多的数据库,由用户,媒体,备份和其他文件上传的文件。

网络服务器

Apache,nginx,Microsoft IIS或任何其他具有正确PHP支持的Web服务器。

数据库

  • 使用PDO的MySQL 5.0.15 / MariaDB 5.1.44 / Percona Server 5.1.70或更高版本,
  • 使用PDO的PostgreSQL 8.3或更高版本,
  • SQLite 3.3.7或更高版本

的PHP

PHP 5.2.5或更高版本(建议5.4或更高版本)。

Drupal 7由Drupal官方页面提供的要求 这里 并随时可能更改。

Drupal 8要求

网络服务器

Apache,nginx,Microsoft IIS或任何其他具有正确PHP支持的Web服务器。

数据库服务器

  • MySQL 5.5.3
  • MariaDB 5.5.20
  • Percona服务器5.5.8
  • (以InnoDB作为主要存储引擎的更高版本或更高版本,并且需要PDO数据库扩展)
  • PostgreSQL 9.1.2或更高版本
  • 支持SQLite 3.6.8或更高版本
  • 其他模块支持Microsoft SQL Server和MongoDB。

支持的PHP版本

PHP versionSupportedRecommended?5.55.5.9+

No5.6Yes

No7.0Yes

No7.1Yes

自Drupal 8.5.0起为7.2是*

Drupal 8要求Drupal官方页面 这里 并随时可能更改。

0
订阅评论
提醒
0 评论
内联反馈
查看所有评论