Jetpack 7.6 改进了 AMP 兼容性,为仅在付费计划中可用的块添加了预览和升级微调

Jetpack 7.6 于本周发布,对该插件的 AMP 兼容性进行了多项改进.Automattic 是 Google AMP 项目最早的发布合作伙伴之一,也是 WordPress 官方 AMP 插件的原作者.此版本使 Jetpack 的另外三个功能与 AMP 兼容:

  • 相关帖子现在显示在 AMP 视图中.
  • AMP 图像现在通过 Jetpack 的图像 CDN 呈现(如果模块处于活动状态).
  • AMP 插件现在能够设置 Jetpack 共享按钮的样式,而无需加载任何额外的 CSS.

针对 7.7 里程碑计划进行更多 AMP 兼容性改进,包括对 WordAds 块的 AMP 支持.

7.6 版还修复了 Simple Payments 描述输出中的一个安全漏洞.此修复仅影响拥有 Premium 或 Professional 计划并使用"简单付款"按钮销售产品或收集捐款的人.

Jetpack 正在 Beta 版测试仅在付费计划中可用的块的预览和升级微调

Jetpack 正在测试一种在块编辑器中营销其付费计划的新方法.此版本中更有趣的新增功能之一是该插件现在允许在编辑器中插入和预览任何 Jetpack 块,即使该块只能通过付费计划获得.尽管它作为 7.6 版本的一部分包含在内,但它似乎目前仅对启用了 Beta 测试的网站有效.

第一次迭代被合并为一个通用解决方案,可以扩展到所有高级块,但它目前仅适用于简单支付块.在此更新之前,免费和个人计划的用户不会在块插入器中看到 Simple Payments 块.此更改将 Simple Payments 块添加到可用块列表中,并允许用户插入和预览它.除非用户升级,否则该块不会显示在前端.

点击升级轻推将用户带到预先选择了计划的结账处,然后在他们购买使用块所需的计划后将他们放回编辑器.在对 Simple Payments 块进行初始实施后,Jetpack 团队计划对 Recurring Payments、VideoPress 和 WordAds 块执行相同的操作.

很容易理解为什么发布帖子中省略了这个有争议的插件添加.它为用户在不升级的情况下无法访问的功能添加了新块.WordPress.org 主题目录也遇到了类似的问题,贾斯汀·塔德洛克 (Justin Tadlock) 将其描述为"瘫痪软件".某些功能被锁定在追加销售之后.

如果 Jetpack 的实现流行起来并且其他插件也效仿,它可能会导致块插入器成为一个令人沮丧的雷区.用户从现有块中选择,不知道他们插入的块是否需要付费升级,直到追加销售弹出到编辑器中.这是一种值得关注的区块编辑器营销策略,因为 Jetpack 将其推出更多仅限于付费计划的区块.

VPS1352主机测评网(www.vps1352.com)
本文链接:https://www.vps1352.com/jetpack-7-6-improves-amp-compatibility-by-adding-blocks/

1
订阅评论
提醒
0 评论
内联反馈
查看所有评论