插件团队划清界限:插件不得更改 WordPress 的默认自动更新设置

WordPress’插件团队发布了关于插件对用户进行更改的声明;更新服务:

除非您的插件具有管理更新的目的,否则您不得 更改 WordPress 的 默认设置’更新设置.

您可以提供自动更新功能,但它必须遵循核心设置.这意味着如果有人将他们的网站设置为"从不更新我的任何插件或主题";除非他们选择加入并提出要求,否则您不得为他们更改这些内容.

该声明是由超出此边界的插件引发的,直到最近,它才被简单理解但并未明确禁止.Mika Epstein 说这种做法"破坏了用户对你不要破坏他们网站的信念."当插件作者滥用核心功能为自己的利益服务时,它也反映了整个 WordPress 的糟糕表现.

“不幸的是,这最近发生在一个使用良好的插件上,而且后果非常糟糕,”爱泼斯坦说.

她没有确定有问题的插件,但上个月发生的一起特定事件与此描述非常相似.2020 年 12 月 21 日,多合一 SEO 插件在不通知用户的情况下开启了自动更新,除了更改日志中的简短、含糊不清的注释.

在推出此更新时,多合一 SEO 在超过 200 万个 WordPress 网站上处于活跃状态.尽管已关闭插件的自动更新,但许多用户发现他们的网站未经许可就被更新了,这让许多用户感到沮丧.该插件的开发人员本月早些时候从插件中删除了自动更新包装器功能,转而让 WordPress 处理更新.

在这件事之后,那些受影响的人留下了疑问.WordPress 应该允许这种做法吗?如果插件开发人员要打开自动更新,是否应该要求他们在仪表板中放置通知?虽然许多用户愿意信任 WordPress 核心以安全的方式进行自动更新,但有些用户不愿意将这种信任扩展到插件开发人员,他们的更新质量差异很大.插件团队就此事提供指导和沟通对于阻止积极的插件开发者破坏对自动更新仍然脆弱的信任是绝对必要的.

“目前,我们没有计划在指南中详细说明这一点,”爱泼斯坦说.“我们目前会定期标记超出其规定(自定义)边界的插件,这不是变化.请尊重您的用户.”

3
订阅评论
提醒
0 评论
内联反馈
查看所有评论